Re: [OT]Dual GPU - help on the way

From: Per olof Ljungmark <peo_at_nethead.se>
Date: Fri, 2 Jul 2021 17:07:25 +0200
On 7/2/21 4:44 PM, Michael Gmelin wrote:
> 
> 
> On Fri, 2 Jul 2021 16:29:59 +0200
> Per olof Ljungmark <peo_at_nethead.se> wrote:
> 
>> On 7/2/21 4:03 PM, Milan Obuch wrote:
>>> On Fri, 2 Jul 2021 15:52:12 +0200, Per olof Ljungmark
>>> <peo_at_nethead.se> wrote:
>>>    
>>>> Slightly frustrated I'm asking on this list.
>>>>
>>>> The setup is HP Z620 with dual Nvidia K2000 and three monitors, the
>>>> aim is to have the desktop (xfce4) extended to all three.
>>>>
>>>> It should be doable with this setup but so far all efforts failed.
>>>>
>>>> With a "standard" xorg.conf, I get the desktop on monitor 1 and 2,
>>>> the third is a black screen but I can move the pointer into it.
>>>>
>>>> Alternatively I could run another X session on X screen 1 instead
>>>> of extending the desktop.
>>>>
>>>> Help welcome!
>>>>
>>>> Thank you in advance,
>>>> Per
>>>>   
>>>
>>> Hi,
>>>
>>> I have zero experience with Nvidia, but I use some devices with
>>> multiple video outputs - board with VGA + DVI or VGA + HDMI, mostly
>>> Intel video. In my case crucial was right use of xrandr, example:
>>>
>>> xrandr --output DVI-D-1 --auto
>>> xrandr --output VGA-1 --auto
>>> xrandr --output VGA-1 --left-of DVI-D-1
>>>
>>> While this could not be answer for you, I'd recommend running
>>>
>>> xrandr
>>>
>>> with no option, just to see if it offers any usefull info.
>>>
>>> In any case, I'd like to know how you are using XFCE in
>>> multi-monitor scenario.
>>
>> xrandr shows the outputs for the second card as "disconnected" so not
>> much I can do there I think.
>>
>> For multi monitor with xfce, I never had a problem with a dual
>> monitor setup and xfce, now I need to add a third.
>>
> 
> Could you try to start X without any configuration and then share the
> output of xrandr with us?
> 

It is not very informative:

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 800 x 600, current 800 x 600, maximum 800 x 600
default connected 800x600+0+0 0mm x 0mm
    800x600        0.00*

With the xorg.conf in my first message:

Screen 0: minimum 8 x 8, current 3840 x 1200, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 connected primary 1920x1200+0+0 (normal left inverted right x axis 
y axis) 519mm x 324mm
    1920x1200     59.95*+
    1920x1080     59.93
    1680x1050     59.95
    1600x1200     60.00
    1280x1024     60.02
    1280x960      60.00
    1024x768      60.00
    800x600       60.32
    640x480       59.94
DP-3 connected 1920x1200+1920+0 (normal left inverted right x axis y 
axis) 519mm x 324mm
    1920x1200     59.95*+
    1920x1080     59.93
    1680x1050     59.95
    1600x1200     60.00
    1280x1024     60.02
    1280x960      60.00
    1024x768      60.00
    800x600       60.32
    640x480       59.94
Received on Fri Jul 02 2021 - 15:07:25 UTC

Original text of this message