Re: iwlwifi: i7260 does not load firmware properly/wifi not working

From: Kevin Oberman <>
Date: Tue, 22 Mar 2022 23:53:24 UTC
On Tue, Mar 22, 2022 at 6:23 AM Bjoern A. Zeeb <> wrote:

> On Tue, 22 Mar 2022, Emmanuel Vadot wrote:
> > There is a lot of reasons for having drivers compiled into the kernel
> > or loaded by loader(8), for me one is to have a small mfsroot (either
> > embedded or not) without any kernel modules.
> Yeah, I have those myself plenty.  Even then I can often load
> drivers after the facts from e.g. NFS root, or the partition holding
> /boot/kernel mounted ro.  But those are "custom" setups.
> > I'd argue that if a driver can't be loaded via loader or compiled into
> > the kernel it's a bug that we have to fix (and yes I know this is the
> > case for DRM).
> Wireless drivers can still be loaded from loader;  in those cases
> people just need to load the appropriate firmware manually as well.
> What I am trying to say is that it should just not be the default
> as most users on a laptop or desktop don't actually need the driver to
> get to multi-user.
> /bz
> --
> Bjoern A. Zeeb                                                     r15:7
> Ouch! Never thought to confirm that iwlwifi was in devd.conf! That seems
to have fixed it.

N.B. I simply hand edited the patch (add iwlwifi and delete wi) and
rebooted. It worked correctly and, for the first time, the network came up
properly with no intervention. The patch should have fixed the problem and
with only a single test, it appears that it did.

Kevin Oberman, Part time kid herder and retired Network Engineer
PGP Fingerprint: D03FB98AFA78E3B78C1694B318AB39EF1B055683