[Bug 263613] iwlwifi0 on framework laptop crashes when setting IP

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 28 Apr 2022 01:44:10 UTC

--- Comment #8 from Jonathan Vasquez <jon@xyinn.org> ---
Hey Chris,

Thanks for that :). So I've been playing around with the system for the whole
day today trying to understand the behavior of this machine in conjunction with
FreeBSD and its drivers. There's just too many variables to explain everything
but the good news is that with Chris' suggestion, DHCP now works on the
iwlwifi0 adapter. DHCP doesn't work on the rwtn0 device though (I'm testing
both to further test the interaction of the drivers and the hardware). All the
devices are working on Linux from the last time I tested them. Static IP
assignment still crashes the iwlwifi0 device, and I was able to get Static IP
working in the rwtn0 device but it doesn't consistently work across -immediate-
reboots (I haven't tested more cold scenario since as I said, I was playing
around with it for the whole day lol). Sometimes it takes 15 seconds for it to
work, sometimes it takes 45+ seconds, and something it just doesn't work. 

There were also some other settings I was missing during static ip assignment,
specifically setting the: defaultrouter="<ip>" field. I was able to test this
through /etc/rc.conf + service netif restart, and I also tried to manually
construct the device and see if it worked. It basically yielded the above


ifconfig wlan0 create wlandev rwtn0
ifconfig wlan0 up
ifconfig wlan0 scan (Shows the AP)

wpa_supplicant -i wlan0 -c /etc/wpa_supplicant.conf


On another terminal (tmux):

ifconfig wlan0 inet netmask

route add default
echo "nameserver" > /etc/resolv.conf

ping (No response, non-deterministic as above results described)

netstat -rn and arp -a showed what you would expect in a correct working
network (like the default gateway being set to and the iface it
used as wlan0).


So yea, lots of different interactions here. I also noticed sometimes if I left
the "ifconfig_ue0="DHCP" in the file, sometimes I wouldn't get a DHCP request
on the wireless card side.. but after many hours later I tried leaving both of
them enabled and it was still working fine.. so it could have just been some
weirdness. I even rebooted my router just to make sure (even though everything
was working, including multiple other machines connected to the same router).

this is my current /etc/rc.conf for further info

root@leslie:~ # cat /etc/rc.conf

kld_list="i915kms if_iwlwifi"


ifconfig_wlan0="WPA SYNCDHCP"

create_args_wlan0="regdomain FCC country US"


##### Other

#ifconfig_wlan0="inet netmask ssid Summerland WPA"
#ifconfig_wlan0="WPA SYNCDHCP"

Either way, at least we were able to find another bug (the static ip assignment
on the iwlwifi0 card causes a crash).

You are receiving this mail because:
You are the assignee for the bug.