[Bug 257914] iwm wlan0 interface not RUNNING after netif restart.

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 17 Aug 2021 13:10:11 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257914

            Bug ID: 257914
           Summary: iwm wlan0 interface not RUNNING after netif restart.
           Product: Base System
           Version: 13.0-RELEASE
          Hardware: amd64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: wireless
          Assignee: wireless_at_FreeBSD.org
          Reporter: unitrunker_at_gmail.com

This worked on 11.x-RELEASE and 12.x-RELEASE but now on 13.0-RELEASE ...

I have a laptop with Intel 7260 wifi.

loader.conf:
iwm7260fw_load="YES"

rc.conf:
wlans_iwm0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"


When I run service netif restart I see an unfamiliar error message:

Aug 17 07:11:14 thinkpad wpa_supplicant[1781]: ioctl[SIOCS80211], op=20, val=0,
arg_len=7]: Invalid argument
Starting dhclient.
wlan0: no link .................. giving up
/etc/rc.d/dhclient: WARNING failed to start dhclient

The wlan0 interface fails to start. Typing ifconfig wlan0 shows the device is
not running. dmesg shows the interface UP and then DOWN.

I can type "ifconfig wlan0 up" to get it running. ifconfig wlan0 scan will show
a list of access points - but it won't associate.

If I add "NOAUTO" to rc.conf:
ifconfig_wlan0="WPA DHCP NOAUTO"

... the interface will associate to some random, open access point.

I expect the interface to (a) stay UP and (b) associate only to what's in
wpa_supplicant.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Tue Aug 17 2021 - 13:10:11 UTC

Original text of this message