Re: CURRENT: bhyve: xfreerdp doesn't support OpenSSL 3 yet. Alternatives?

From: Guido Falsi <>
Date: Thu, 29 Jun 2023 16:58:36 UTC
On 29/06/23 18:34, FreeBSD User wrote:
> Am Thu, 29 Jun 2023 16:41:51 +0200
> Guido Falsi <> schrieb:
>> On 29/06/23 16:35, FreeBSD User wrote:
>>> Hello,
>>> running a recent CURRENT, 14.0-CURRENT #10 main-n263871-fd774e065c5d: Thu Jun 29 05:26:55
>>> CEST 2023 amd64, xfreerdp (net/freerdp) doesn't working anymore on Windows 10 guest in
>>> bhyve. It seems OpenSSL 3 is the culprit (see the error message from xfreerdp below). I
>>> opened already a PR (see: In a
>>> very quick response I was informed that recent FreeRDP doesn't support OpenSSL 3 yes
>>> (
>>> Checking for HowTo's setting up bhyve guests, I dodn't realise any setting for
>>> alternatives to RDP. As I do not fully understand how bhyve passes through its guest's
>>> framebuffer device/ or native GUI, I'm a bit helpless in searching for another solution to
>>> contact the Windows10 guest from the X11 desktop of the hosts.
>>> Trying remmina turns out to be a fail, because in our installation libsoup2 and libsoup3
>>> are installed both and remmina complains about having both symbols, also I realised
>>> remmina seems to utilize net/freerdb as the RDP backend.
>>> Since I have no clue how to install "blindly" a VNCserver within the Windows10 guest, I
>>> presume VNC is not an option in any way.
>>> Is there any way to access the bhyve guest's native graphical interface? As in the PR shown
>>> above already documented (setup taken from the FreeBSD Wiki/bhyve), a framebuffer is
>>> already configured.
>>> It would be nice if someone could give a hint.
>> I had the same issue, with Windows 10 pro hosts, but the fault is in
>> windows, which, by default, tries to negotiate an ancient protocol (NTLM
>> using RC4 if I understand correctly).
>> With modern windows RDP servers there are better protocols available,
>> you can get them in remmina by forcing "TLS protocolo security" in the
>> advanced tab, security protocol negotiation (second row).
>> Doing this (after some experimentation with various options) solved the
>> issue for me.
> Thank you very much for the quick response.
> net/remmina is not an option on most of my workstations, since some required ports install
> libsoup3, and remmina complains about having found libsoup2 symbols as well as libsoup3
> symbols when starting up - and quits.

I am using remmina and told you how I fixed it.

> Since remmina utilises net/freerdp, I was wondering if I could enforce TLS security by any
> kind of a switch, and trying the following
>   xfreerdp /v: /u:ohartmann /sec:tls

I'm no expert of the xfreerdp command line, but there are many options, 
you'll need to experiment.

> resulting in
> [...]
> [17:58:18:972] [1702:bb812700] [WARN][com.winpr.utils.ssl] - OpenSSL LEGACY provider failed to
> load, no md4 support available!

It's stull trying to use MD4, most probably for authentication, try to 
disable NTLM authentication, or completely disable authentication (could 
require some extra configuration in windows to work)

> I can not interpret the error above.
> bhyve is novel to me and I have to admit that I make some capital mistakes here - but can't
> find satisfying doucumentation ...
Bhyve has nothing to do with it. bhyve has no knowledge of RDP. It is 
the OS running inside it providing RDP and the related 

I'm almost sure you would be facing the same exact issue trying to 
connect via RDP to a separate physical Windows 10 pro machine on the 

Guido Falsi <>