Re: trying to attach another disk to openbsd72 bhyve guest

From: void <>
Date: Sun, 06 Nov 2022 19:08:22 UTC
Hello Peter,

On Sun, 6 Nov 2022, at 11:16, Peter Grehan wrote:

> I tried this out with 7 disks, 6 added post-install, and OpenBSD 7.2 was 
> able to see them. Info appended.

Thanks for this, I'll try to replicate your results here

> What version is the FreeBSD host ? I tested on CURRENT.

Ah, all the systems I've tested on have been some version of 13-stable.

Tested on:

on all of them there's various WITHOUT_* options in /etc/src.conf. One of these machines I can upgrade to no-debug current with a minimum of options in src.conf. You're using slightly different bhyve options to me, so I'll try those too.

I've found that if openbsd gets as far as the bootloader, one can quickly set 'set tty com0' to see the output in a console so no vnc is needed.

Some additional info:
I've also had problems [1] post-install running the openbsd72 bhyve instance. 
Seems it can't find the efi/boot. The installer runs ok but it seems no (msdos) efi partition gets created in the install process.[2] I have worked around this by firstly preparing the destination disk with gpart, creating a 1GB msdos partition (in for example a 64gb .img) then running the installer and telling it to install to the empty part of the img. Then mounting the msdos part with mdconfig and copying the whole path efi/boot/bootx64.efi into it. This is the only way I've got an openbsd72 bhyve guest running.

With virtualbox 7 on linux:
I can create an openbsd72 guest easily, remove the installation image and boot the guest within virtualbox. It runs as a VDI image. I've converted a copy of the vdi to raw with qemu-img then transferred it to a freebsd box but bhyve still won't boot it.

[1] BdsDxe: failed to load Boot0001 "UEFI BHYVE SATA DISK BHYVE-FCAF-9707-5087" from PciRoot(0x0)/Pci(0x3,0x0)/Sata(0x0,0xFFFF,0x0): Not Found

BdsDxe: failed to load Boot0002 "UEFI Misc Device" from PciRoot(0x0)/Pci(0x4,0x0): Not Found

>>Start PXE over IPv4.

(repeats a few times, then drops to Shell> ) where I type exit and get to the ncurses/graphical uefi shell with a grey background. Then select from the boot menu and get to the one where it says boot from a file, hit enter but no file is found.

[2] checked with mdconfig the only partition post-install is md0p4 which is ffs/ufs.