[Bug 255251] The ue0 device has an unstable network connection

From: <bugzilla-noreply_at_freebsd.org>
Date: Sun, 26 Sep 2021 06:58:53 UTC

--- Comment #5 from Michael Reim <kraileth@elderlinux.org> ---
I have experienced this problem, too, on a Dell XPS laptop (manufactured late
2019) which has no ethernet socket and thus forces me to use a USB2LAN adapter.
I've tried out two: The Dell one that came with the laptop and an Anker one
that I've been using without problems e.g. when playing with my Pinebook and
FreeBSD. Both are directly (no HUB or such) attached with traditional USB plugs
(not USB-C). I've uploaded dmesgs for system starts with either adapter

I've observed that networking generally does work. After installing 13.0, I had
trouble running freebsd-update. It started to download files but then the
system would lose connection (state for ue0 changes from active to no carrier.
Removing the network plug and putting it back didn't help but pulling out the
USB connector and reattaching it did. However the same thing happened if I
tried to run freebsd-update again.

Updating briefly worked with the other (Anker) adapter, so I continued building
my system. I was able to zfs send over 100GB to the laptop without the network
having any issue, install a lot of packages for desktop use and so on. But when
I tried to use Ansible to provision another machine from the XPS, network
connection would immediately break. So I decided to clone the FreeBSD source
and update to 14-CURRENT to see if it happens there, too. Unfortunately cloning
a git repo triggers the same problem.

Therefore I cloned it on another machine and scp'd it over. System is running
14-CURRENT now and the situation has improved (cloning seems to work now) and
Ansible can do a few tasks instead of losing connection immediately, but
ultimately it still fails after a moment.

This is all a bit weird. I know that the Anker one works just fine with other
hardware and I briefly tested the Dell one on another laptop as well without
any problems. And since 14-CURRENT behavior definitely is different from 13.0,
some related work seems to have been done. A former co-worker used the machine
with Ubuntu installed and I don't know of any network issues.

I hope this helps with identifying what the actual problem is. I'd be happy to
answer questions or provide additional info.

You are receiving this mail because:
You are the assignee for the bug.