installing to usb3 disk or thumbdrive, result isn't bootable

From: void <>
Date: Mon, 31 Jul 2023 17:42:21 UTC
Hi stable@

I'm having odd problems booting an installation to usb3 disk or stick.


1. download (e.g:)
2. write it to usb3. We'll call this one the installation usb3
3. boot it up and plug in the destination device (destination usb3)
4. install to the destination usb3 using either auto-ufs or auto-zfs
5. turn off the computer, unplug the installationn usb3, leave the destination plugged in.
6. attempt to boot up. 

Note that despite selecting the destination usb3 in the bios and booting to it, instead of the expected
freebsd logo, the screen is black apart from a flashing cursor top left which flashes for 5 secs or so, stops
then does it again, 8 or 10 times (on my computer i get dumped to the bios config screen after this time).

I thought maybe there was something wrong with the destination usb3 so in order to test,
I wrote the downloaded memstick.img to *that*. Rebooted the computer and it loads the installer as expected.

What's going on? it's like the installer hasn't told the destinationn that it's supposed to boot.
In all instances the *entire disk* was used.

Also tried this with 13.1-R and 14-current as of the 27th July with the same result.
Also tried using dvd as installation media, usb3 as destination, same result. The auto-ufs installs all
used GPT not MBR

Next to try is setting destination usb3 MBR/ufs2 and setting it active in alt-f4 before booting.

gpart show da4 on the install media shows slice 2 [freebsd] as active in mbr