Re: FreeBSD boot from root pool larger than 1Tb/cannot read MOS/all block copies unavailable

From: Tomoaki AOKI <>
Date: Wed, 27 Apr 2022 12:45:02 UTC
On Tue, 26 Apr 2022 19:10:51 +0500
"Eugene M. Zheganin" <> wrote:

> Hello,
> recently I found another server that was running 12.x and became 
> unbootable because of the famous "cannot read MOS/all block copies 
> unavailable/etc" gptzfsboot message which can be randomly displayed when 
> boot blocks migrate beyond 1st Tb on a large root pool. I managed to 
> boot the server from CD (pointing out the root pool with 
> vfs.root.mountfrom) and then upgraded it to the recent 13.0, where is 
> showed no signs of being able to boot from disks again (so I'm treating 
> this as still not fixed, and probably as won't be fixed issue).
> Since this issue is like 10 years old and I see no light at the end of 
> the tunnel, could the bsdinstall at least be made aware about this so it 
> won't permit the large root pool creation by default ? Because as far as 
> I remember there's still no option in it to create a pool smaller than 
> the disk, and I have to use the custom installation script in order to 
> do this.
> I'm asking because unfortunately recently I've found two more of these 
> time bombs among my servers.
> Thanks.
> Eugene.
> P.S. There have been speculations that switching to the UEFI loader may 
> help, because it's more functional and probably can see the migrated 
> over 1Tb boot blocks, can anyone confirm this ?

I've booting with around 1.5T or above (but under 2T) Root-on-ZFS
installation via UEFI for years.

Basically, UEFI requires GPT partitioning. So many of those would boot
from larger than 1TB boot pool.

As, IIRC, it is optional, some UEFI firmware would be able to boot from
MBR-patritioned disk but there would be some risk that they have the
same limitations as legacy BIOS in such situations.

Note that possibly I'm just lucky enough not to be bitten.

Tomoaki AOKI    <>