Re: pkg postgresql-client

From: Baptiste Daroussin <bapt_at_FreeBSD.org>
Date: Wed, 27 Oct 2021 10:20:52 +0200
On Wed, Oct 27, 2021 at 09:54:14AM +0200, ml_at_ft-c.de wrote:
> Hello, 
> 
> I have install postgresql version 13 
> (and in a few weeks I switch to version 14) 
> 
> When I install R-studio, then pkg would change/downgrade the
> postgresql-client version from 13 to 12. 
> 
> pkg install Rstudio
> Updating FreeBSD repository catalogue...
> FreeBSD repository is up to date.
> All repositories are up to date.
> The following 3 package(s) will be affected (of 0 checked):
> 
> New packages to be INSTALLED:
>         RStudio: 1.4.1717_2
>         postgresql12-client: 12.8
>         soci: 4.0.1_1
> 
> This error has existed for more than 5 years.
> 
> Franz
> 
> uname -a :> FreeBSD  13.0-RELEASE-p4  amd64
> 
> 
> 

Welcome to the postgresql hell (same applies to mysql family) on freebsd

This is because on freebsd beside the fact that multiple version exists in the
ports tree only the "default" can be used when using binary packages.

I have posted a proposal on how to make any postgresql installable in parallel,
shoudl be around 6 years ago, unfortunatly noone implemented it since :(, my
proposal would have eliminated the concept of default and let the user pick the
version it needs.

https://lists.freebsd.org/pipermail/freebsd-ports/2015-July/099842.html

Best regards,
Bapt
Received on Wed Oct 27 2021 - 08:20:52 UTC

Original text of this message