maintainer-feedback requested: [Bug 256622] devel/rubygem-inspec-core: Broken rubyzip dependency

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 15 Jun 2021 18:08:28 +0000
Bugzilla Automation <bugzilla_at_FreeBSD.org> has asked freebsd-ruby (Nobody)
<ruby_at_FreeBSD.org> for maintainer-feedback:
Bug 256622: devel/rubygem-inspec-core: Broken rubyzip dependency
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256622



--- Description ---
Gemspec adds dependency on rubyzip verion 1.2, which is not available:

       s.add_runtime_dependency(%q<rubyzip>.freeze, ["~> 1.2", ">= 1.2.2"])

Trying to use the gem ends with error message:

Unable to activate inspec-core-4.24.8, because rubyzip-2.3.0 conflicts with
rubyzip (~> 1.2, >= 1.2.2)

It was updated in upstream to: ">= 1.2.2", "< 3.0"

https://github.com/inspec/inspec/commit/fe9a1c8dd5f76a5d4c17be806d8a2ebc5fd7f0f
3
Received on Tue Jun 15 2021 - 18:08:28 UTC

Original text of this message