[Bug 259160] x11-servers/xorg-server: fix build on riscv64

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 13 Oct 2021 22:16:07 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=259160

            Bug ID: 259160
           Summary: x11-servers/xorg-server: fix build on riscv64
           Product: Ports & Packages
           Version: Latest
          Hardware: riscv
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: x11_at_FreeBSD.org
          Reporter: fuz_at_fuz.su
                CC: riscv_at_FreeBSD.org, x11_at_FreeBSD.org
          Assignee: x11_at_FreeBSD.org
             Flags: maintainer-feedback?(x11_at_FreeBSD.org)
                CC: riscv_at_FreeBSD.org
 Attachment #228684 maintainer-approval?(x11_at_FreeBSD.org)
             Flags:
                CC: x11_at_FreeBSD.org

Created attachment 228684
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=228684&action=edit
x11-servers/xorg-server: fix build on riscv64

With this patch I was able to build x11-servers/xorg-server on a patched
riscv64 FreeBSD 13-STABLE.  I cannot test if it builds and works on vanilla
riscv64.  The patch basically tells the build system to use the IO access setup
code from ARM for RISC-V, too.  It seems to work and I can start an X server
(but didn't get a picture due to a configuration issue it seems).

Needs additional QA.

Related to bug #259158 and bug #259159.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Wed Oct 13 2021 - 22:16:07 UTC

Original text of this message