error creating thin jail on 15.0

From: Graham Menhennitt <graham_at_menhennitt.com.au>
Date: Tue, 23 Dec 2025 05:40:20 UTC
Hello,

I've recently upgraded my server from 14.3 to 15.0. Everything appeared 
to work successfully in the upgrade.

I now want to create a thin jail using UFS. I've followed the handbook 
section 17.5 exactly except that my jail is named "vaultwarden" instead 
of "thinjail". Accordingly, I've replaced "thinjail" by "vaultwarden" 
everywhere.

When I try to start the jail, I get an error:

# service jail start vaultwarden
Starting jails: cannot start jail  "vaultwarden":
jail: vaultwarden: mount.devfs: 
/usr/local/jails/containers/vaultwarden/dev: No such file or directory
.
#

I tried creating directory /usr/local/jails/containers/vaultwarden/dev. 
Then I get a different error:

# service jail start vaultwarden
Starting jails: cannot start jail  "vaultwarden":
1
jail: vaultwarden: /bin/sh /etc/rc: failed
.
#

I'm completely new to jails. Can somebody please give me a clue on how 
to diagnose then problem.

Thanks in advance,

     Graham