[Bug 257073] www/mitmproxy: Fails to build after py-asgiref 3.4.1 upgrade

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 14 Sep 2021 08:19:26 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257073

--- Comment #10 from p5B2E9A8F_at_t-online.de ---
The port still does not build:
=======================<phase: run-depends    >============================
===== env: USE_PACKAGE_DEPENDS_ONLY=1 USER=root UID=0 GID=0
===>   mitmproxy-6.0.2 depends on package: py38-asgiref>=3.2.10<3.4 - not found
===>   Installing existing package /packages/All/py38-asgiref-3.4.1.pkg
[12amd64-default-jails-job-02] Installing py38-asgiref-3.4.1...
[12amd64-default-jails-job-02] Extracting py38-asgiref-3.4.1: .......... done
===>   mitmproxy-6.0.2 depends on package: py38-asgiref>=3.2.10<3.4 - not found
*** Error code 1

Stop.
make: stopped in /usr/ports/www/mitmproxy
=>> Cleaning up wrkdir
===>  Cleaning for mitmproxy-6.0.2
build of www/mitmproxy | mitmproxy-6.0.2 ended at Tue Sep 14 10:00:53 CEST 2021
build time: 00:00:07
!!! build failure encountered !!!

A patch exists:  Hung-Yi Chen 2021-07-10 21:01:36 UTC
A commit never happened.

Upstream moved to 7.0.2 (4 August 2021).

Work on this bug seam to be stuck. What action has to be taken here?

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Tue Sep 14 2021 - 08:19:26 UTC

Original text of this message