[Bug 256082] www/py-werkzeug: Fails to configure on Python 3.6: ModuleNotFoundError: No module named 'dataclasses'

From: <bugzilla-noreply_at_freebsd.org>
Date: Sun, 30 May 2021 21:35:44 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256082

John W. O'Brien <john_at_saltant.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |Overcome By Events
             Status|Open                        |Closed

--- Comment #1 from John W. O'Brien <john_at_saltant.com> ---
This is resolved by 

commit f1b3354553cf451bb19feda2787d900162b6e936
Author: Po-Chuan Hsieh <sunpoet_at_FreeBSD.org>
Date:   Sat May 22 22:43:05 2021 +0800

    www/py-werkzeug: Update to 2.0.1

    Changes:        https://github.com/pallets/werkzeug/releases

https://cgit.freebsd.org/ports/commit/?id=f1b3354553cf451bb19feda2787d900162b6e936

and

commit 4aedd48f96fbd2a8339cb24837efe8e36250862c
Author: Dima Panov <fluffy_at_FreeBSD.org>
Date:   Mon May 24 12:03:34 2021 +1000

    www/py-werkzeug: py-dataclasses should be in BUILD_DEPENDS too for use with
python36

    Noticed by:     poudriere failure
    Pointy hat to:  sunpoet_at_

https://cgit.freebsd.org/ports/commit/?id=4aedd48f96fbd2a8339cb24837efe8e36250862c

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Sun May 30 2021 - 21:35:44 UTC

Original text of this message