[Bug 251626] math/py-numpy: update to 1.19.4 (compatible with Python 3.9)

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 27 May 2021 11:37:00 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=251626

Thierry Thomas <thierry_at_FreeBSD.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|New                         |Open

--- Comment #22 from Thierry Thomas <thierry_at_FreeBSD.org> ---
(In reply to Antoine Brodin from comment #21)

Indeed, Mk/Uses/python.mk must be adapted:
PYNUMPY=  
${PYTHON_PKGNAMEPREFIX}numpy>=1.16,1<1.20,1:math/py-numpy_at_${PY_FLAVOR}

_at_python team, what about this patch?

diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index fcaf479d8076..5e2682d8efd6 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
_at__at_ -640,7 +640,7 _at__at_ CMAKE_ARGS+=       
-DPython_ADDITIONAL_VERSIONS=${PYTHON_VER}

 # Python 3rd-party modules
 PYGAME=               
${PYTHON_PKGNAMEPREFIX}game>0:devel/py-game_at_${PY_FLAVOR}
-PYNUMPY=      
${PYTHON_PKGNAMEPREFIX}numpy>=1.16,1<1.20,1:math/py-numpy_at_${PY_FLAVOR}
+PYNUMPY=      
${PYTHON_PKGNAMEPREFIX}numpy>=1.16,1<1.21,1:math/py-numpy_at_${PY_FLAVOR}

 # Common Python modules that can be needed but only for some versions of
Python.
 .if ${PYTHON_REL} < 30500

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Thu May 27 2021 - 11:37:00 UTC

Original text of this message