[Bug 251626] math/py-numpy: Update to 1.20.3 (compatible with Python 3.9)

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 02 Jun 2021 08:10:21 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=251626

--- Comment #37 from Thierry Thomas <thierry_at_FreeBSD.org> ---
(In reply to Kubilay Kocak from comment #36)

Kubilay,

As much as I can admit the usage of autoplist for lazy porting of a minor port
which installs 5 or 6 files, for a port as important as Numpy, I don't
understand it , and IMHO it would be a mistake, especially if you have to patch
it in order to fix autoplist!

- a static plist allows you to simply answer the question "which port installs
this particular file?" with a grep even if not installed;

- during an upgrade, this is easy to see if some important files are missing
due to an unoticed error.

For example, the case reported by Antoine in Comment 35 (optimized files
missing with Python-3.7) would not even have been noticed with an autoplist!

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
Received on Wed Jun 02 2021 - 08:10:21 UTC

Original text of this message