[Bug 251626] math/py-numpy: Update to 1.20.3 (compatible with Python 3.9)

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 24 Jul 2021 17:53:45 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=251626

--- Comment #44 from Po-Chuan Hsieh <sunpoet_at_FreeBSD.org> ---
(In reply to Thierry Thomas from comment #33)

PYGAME and PYNUMPY should be removed some day. Unlike other PY_foo, they do not
bring any benefit but make things more complex. For example, it's getting much
harder to check version requirements of dependent ports.

Please do not revert the change for removing PYNUMPY. The correct way is to
patch the source (setup.py, setup.cfg, requestments.txt or other files) and
update RUN_DEPENDS. In this case, it's setup.py.

(In reply to Thierry Thomas from comment #39)

Note that numpy 1.20.* requires Python 3.7.
For a complete patch, you forgot to change USES=python:3.6+ to USES=python:3.7+
and update all dependent ports as well.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.
Received on Sat Jul 24 2021 - 17:53:45 UTC

Original text of this message