[Bug 257312] x11/dsbxinput: Update to 0.1.1

From: <bugzilla-noreply_at_freebsd.org>
Date: Fri, 23 Jul 2021 04:12:11 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257312

--- Comment #3 from Kubilay Kocak <koobs_at_FreeBSD.org> ---
(In reply to Marcel Kaiser from comment #2)

Thanks for the feedback Marcel.

That (3.8) is just the 'current point in time' default version, provided by the
ports framework, not individual ports. The default changes over time, and users
cann choose whatever default version they like (overriding the default).

Individual ports declaratively just specify what versions the package (code)
supports.

In py-qt5's case, that's:

  USES=         metaport python:3.5+ (annythingn from 3.5 up, currently, to
3.10)

In this ports case, whatever python versions the code in dsbxinput.in supports
("actually can run with"). This is a matter of testing the code.

A good best-practice read over how to write as portably as possible (as an
upstream), is:

  https://www.python.org/dev/peps/pep-0394/

For example the shebang line in sdbxinput should likely/probably be
"/usr/bin/env python3" (in that it supports, and will call python3 on user
systems), unless its Python 2/3 compatible in which case "/usr/bin/env python"
might be more suitable.

Don't hesitate to jump on #freebsd-python on LiberaChat IRC if you need support
or have further questions, we're happy to help

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Fri Jul 23 2021 - 04:12:11 UTC

Original text of this message