[Bug 257143] textproc/py-libxml2: Fails to run: libxml2mod.so: Undefined symbol "xmlPopOutputCallbacks" (breaking textproc/itstool -> textproc/gtk-doc / textproc/yelp-xsl

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 13 Jul 2021 04:40:30 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257143

--- Comment #6 from Chris Hutchinson <portmaster_at_bsdforge.com> ---
(In reply to Kubilay Kocak from comment #4)
Thanks for the reply, and all your time here.
Sure. Already having lang/Python37 installed.
I upped my ports tree to work on mail/claws-mail
which I maintain. It has requirements (depends)
that ultimately drag in (py-)libxml2.
The ports that dragged *libxml2 failed to build,
dumping errors similar to that included in this
pr.
The root cause for the failure(s) were not
apparent. So after some time chasing possibilities
I landed at textproc/py-libxml2. Which, of course
depended upon the availability of textproc/libxml2.
The ultimate cure was to make clean && make deinstall
within both of textproc/py-libxml2, and textproc/libxml2.
Followed by a make (re)install in the same.

I _think_ that ports requiring (depending) upon these
two libs should require the newer version (2.9.10_3)
to avoid this problem. This would have signaled my
build to either fail; indicating an older (unsupported)
version was installed. Or up(date|grade) to the required
version.

Does that sound about right? In the end, that was ultimately
what was required.

Thanks again, for all your time, and attention to this.

--Chris

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Tue Jul 13 2021 - 04:40:30 UTC

Original text of this message