[Bug 257073] www/mitmproxy fails to build because py-asgiref was upgraded to 3.4.1

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 10 Jul 2021 21:46:54 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257073

--- Comment #7 from p5B2E9A8F_at_t-online.de ---
# https://packaging.python.org/en/latest/requirements/#install-requires
# It is not considered best practice to use install_requires to pin
dependencies to specific versions.

With this wisdom found there:

https://bugs.freebsd.org/bugzilla/attachment.cgi?id=226359&action=diff#b/www/mitmproxy/files/patch-setup.py_sec1

I do wonder why these are still used here. They should be used only preventing
to break a port but not for intentionally breaking if any dependency got a
working upgrade.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Sat Jul 10 2021 - 21:46:54 UTC

Original text of this message