[Bug 257920] [NEW PORT] devel/py-pycapnp: Cython wrapping of the C++ Cap'n Proto library

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 31 Aug 2021 16:43:35 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257920

--- Comment #7 from Maxim Sobolev <sobomax_at_FreeBSD.org> ---
(In reply to Kubilay Kocak from comment #5)

Thanks Kubilay for a detailed review. Most of the changes have been
incorporated (see the diff for the detailed list), few notes:

[3] Does not apply, since it's only relevant when linking module with a
*static* libcapnp.a (when bundled version is linked). In our case, we are
linking with the libcapnp.so, so it's compiled as PIC on all arches of
relevance.

[4] The setup.py would correctly discover system capnproto library when I
worked on the port, in any case I've added --force-system-libcapnp to enforce
it.

- I've tried the test suite and it fails unfortunately with many module not
found errors. However, all of the examples bundled with the package seems to be
working fine, I verified that before opening the bug request. I am really out
of my time (and depth debugging those issues), which most likely caused by the
test suite itself never tested on anything but Linux, so unless it's a hard
requirement to have a working do-test in port I'd probably skip that for now.
It takes a non-trivial amount of time to make 3rd party test suite to run on
FreeBSD check this out as an example:
https://github.com/capnproto/capnproto/pull/1321

Thanks again!

-Max

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Tue Aug 31 2021 - 16:43:35 UTC

Original text of this message