[Bug 258033] devel/py-b2sdk: Update to 1.12.0

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 25 Aug 2021 01:35:07 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=258033

--- Comment #5 from Kubilay Kocak <koobs_at_FreeBSD.org> ---
(In reply to Henry from comment #4)

Thanks Henry. When doing that (which is fine), either:

- Add comments above the patch block clarifying what/why, like:

 # Remove pinned upper bound version-specs

or

- Do this with an explicit files/patch-* files so the specific dependencies and
changes can be seen.

It's also highly recommended to ask upstream to use appropriate version-specs
for distributed/distribution packages

Lastly, when patching dependency version specs, confirming that the package
still functions appropriately, via upstreams test suite, is absolutely
necessary [1] Can you confirm the port passes tests with current versions of
ports in the tree? 

Thanks!

[1] https://wiki.freebsd.org/Python/PortsPolicy#Modifying_Dependencies

-- 
You are receiving this mail because:
You are on the CC list for the bug.
Received on Wed Aug 25 2021 - 01:35:07 UTC

Original text of this message