multimedia/plexmediaserver vs multimedia/plexmediaserver_plexpass.

From: Janky Jay, III <>
Date: Fri, 18 Feb 2022 04:43:52 UTC
Hi All,

So, I ran into something interesting tonight while messing around with 
Plex Media Server. I'd noticed a while back that updating to the latest 
version of multimedia/plexmediaserver ( I would have issues 
with playback of certain file types (mainly older .wmv's and such.) So, 
I downgraded back to version and all is well again.

Looking further into the issue and wondering why the PMS version was so 
far behind (current version is but I'm not complaining! Just 
hear me out,) I noticed there was another PMS port, 
multimedia/plexmediaserver_plexpass, for what I assumed was intended for 
Plex Pass members/users. Being a lifetime Plex Pass member for quite a 
long time, and seeing that this version was much newer, I gave it a shot.

Installation of the Plex Pass version went fine (I tried both port and 
package) but when I connected to the local Plex server (local RFC1918 
IP, port 32400,) my Plex account wasn't able to connect to my Plex 
server. I could view all the standard online provided Plex media but not 
my own (movies, music, TV shows, etc...) It simply said, "Could not 
connect" (or some variant) and provided a "Retry" button which I did 
click but it just continually failed.

After a while of continuing to try to fix the issue, I gave up and 
re-installed the older version of multimedia/plexmediaserver 
( Voila! Everything worked perfectly fine again. I can 
access all the Plex provided media using my Plex Pass account and I can 
also access my local media that PMS is hosting.

I suppose my query here is - What am I missing?
1. Is the multimedia/plexmediaserver_plexpass port intended for Plex 
Pass customers to have the most recent version and some other spiffy stuff?
2. Is it intended for Plex Pass customers who *ONLY* want Plex Media and 
don't host their own?
3. Is something wrong with the port or configuration that behaves 
differently from the non-plexpass port and it's not able to connect to
4. Perhaps I'm way off?

Any help would obviously be greatly appreciated. As I'd mentioned, I'm 
not complaining. I just figured with the Plex Pass port I'd get a newer 
version and it would maybe provide some perks of being a Plex Pass 
member but it actually seemed to limit my media access. I just want to 
make sure I'm using the correct port/package and also reporting any 
issues I come across. Thanks!

Janky Jay, III