remove unsupported zabbix packages?

From: Martin Waschb├╝sch <martin_at_waschbuesch.de>
Date: Sat, 05 Feb 2022 22:27:34 UTC
Hi there,

I just noticed that zabbix3 (which was a LTS release) is no longer 
officially supported according to their website:

https://www.zabbix.com/life_cycle_and_release_policy

At least with PHP releases, it seems that the end of official support 
also means removal from ports.
Is this, or rather, should this be true for other software as well?

Also, regarding zabbix3-frontend, is that even still working? According 
to:
https://www.zabbix.com/documentation/3.0/en/manual/installation/requirements#frontend
only PHP versions prior to 7.0 where supported.

Seeing as by the end of the year there will not even be any PHP 7.x left 
in ports, not to mention 5.x which has been gone for a long time, it 
looks to me like the port might have to go. If so, the obvious targets 
currently in ports:

zabbix3-agent-3.0.32
zabbix3-frontend-3.0.32
zabbix3-java-3.0.32_1
zabbix3-libzbxpgsql-1.1.0_4
zabbix3-proxy-3.0.32
zabbix3-server-3.0.32

For all of them (except for zabbix3-libzbxpgsql) their successor 
packages are available in versions 4.0 (LTS), 5.0 (LTS) and 5.4 
(supported until March).
So an upgrade path is available.

In case I am right and they should be removed, how is that done? Open a 
PR as with new ports or updates?

Thanks,

Martin