Re: inject IGNORE_OSVERSION in poudriere?

From: Bryan Drewery <bryan-lists_at_shatow.net>
Date: Tue, 7 Sep 2021 14:19:41 -0700
On 7/12/2021 4:07 AM, Ronald Klop wrote:
> Hi,
> 
> To save time I sometimes get pkgs from the official pkg builders and
> save them in the poudriere dir.
> But now and then I get this:
> 
> [00:00:47] ===>   Installing existing package
> /packages/All/llvm11-11.0.1.txz
> [00:00:48] [freebsd14-custom-job-01] Installing llvm11-11.0.1...
> [00:00:48] Newer FreeBSD version for package llvm11:
> [00:00:48] To ignore this error set IGNORE_OSVERSION=yes
> [00:00:48] - package: 1400025
> [00:00:48] - running kernel: 1400024
> [00:00:48] Ignore the mismatch and continue? [y/N]: [00:00:49] Failed to
> install the following 1 package(s): /packages/All/llvm11-11.0.1.txz
> [00:00:49] *** Error code 1
> 
> Normally I delete/create the poudriere jail, but the upstream world used
> by poudriere is not new enough yet.
> 
> How can I set IGNORE_OSVERSION=yes in the poudriere environment?

In poudriere.conf: export IGNORE_OSVERSION=yes

However, poudriere-devel now supports fetching binary packages with -b
flag to bulk.



-- 
Regards,
Bryan Drewery
bdrewery_at_freenode/EFNet
Received on Tue Sep 07 2021 - 21:19:41 UTC

Original text of this message