Re: llvm10 build failure on Rpi3

From: bob prohaska <fbsd_at_www.zefox.net>
Date: Wed, 23 Jun 2021 10:43:38 -0700
On Wed, Jun 23, 2021 at 01:34:55AM -0700, Mark Millard wrote:
> 
> Not that it helps much, but: 2779096485 == 0xA5A5A5A5
> 
> It appears that such somehow was involved-in/generated by:
> 
> [ 24% 1326/5364] cd /wrkdirs/usr/ports/devel/llvm10/work/.build && /wrkdirs/usr/ports/devel/llvm10/work/.build/bin/llvm-tblgen -gen-global-isel -I /wrkdirs/usr/ports/devel/llvm10/work/llvm-10.0.1.src/lib/Target/AMDGPU -I /wrkdirs/usr/ports/devel/llvm10/work/llvm-10.0.1.src/include -I /wrkdirs/usr/ports/devel/llvm10/work/llvm-10.0.1.src/lib/Target /wrkdirs/usr/ports/devel/llvm10/work/llvm-10.0.1.src/lib/Target/AMDGPU/AMDGPUGISel.td --write-if-changed -o lib/Target/AMDGPU/AMDGPUGenGlobalISel.inc -d lib/Target/AMDGPU/AMDGPUGenGlobalISel.inc.d
> 
> and that lead to the commented out notation in the output, with the "_at_2779096485" listed in the comment as well.
> 

A Pi4 doing a bulk build of chromium, lxqt and apache has gone far past that
point building llvm10, suggesting the fault lies somewhere in my setup.

The instructions you gave for setting up poudriere seemed to work perfectly
initially, but since that time both world and kernel have been updated
along with ports. Is it necessary or advisable to alter /usr/local/poudriere,
either by  update commands or complete replacement? 

Thanks for reading, and all your help!

bob prohaska


 
Received on Wed Jun 23 2021 - 17:43:38 UTC

Original text of this message