Re: databases/cockroach: any PPC64|arm64 tester?

From: Ronald Klop <ronald-lists_at_klop.ws>
Date: Tue, 22 Jun 2021 19:12:00 +0200 (CEST)
Van: Ronald Klop <ronald-lists_at_klop.ws>
Datum: 22 juni 2021 09:56
Aan: Pedro Giffuni <pfg_at_FreeBSD.org>
CC: FreeBSD Ports <freebsd-ports_at_FreeBSD.org>
Onderwerp: Re: databases/cockroach: any PPC64|arm64 tester?

> 
> 
> 
> Hi,
> 
> I started a build in poudriere on RPI4 aarch64/13-RELEASE.
> 62 pkgs to go. So we'll see where this ends and I will post the result.
> 
> Regards,
> Ronald.
> 
>  
> Van: Pedro Giffuni <pfg_at_FreeBSD.org>
> Datum: maandag, 21 juni 2021 21:19
> Aan: FreeBSD Ports <freebsd-ports_at_FreeBSD.org>
> Onderwerp: databases/cockroach: any PPC64|arm64 tester?
> > 
> > Hello;
> > 
> > The cockroach port Makefile reads:
> > 
> > ONLY_FOR_ARCHS= amd64
> > ONLY_FOR_ARCHS_REASON=  "A 64-bit system is strongly recommended"
> > 
> > FWIW, It is very likely the port works on other systems but nobody has tried building on them.
> > 
> > I know some people test regularly arm64 and ppc64 so it would be nice to see JIC it builds and perhaps enable it for 64 bit platforms.
> > 
> > Cheers,
> > 
> > Pedro.
> > 
> >  
> > 
> > 
> > 
> 
> 
> 
> 
> 

No luck so far.


[00:01:42] Running make with -j4
[00:01:42] GOPATH set to /wrkdirs/usr/ports/databases/cockroach/work/cockroach-v19.1.11
[00:01:42] Cleaning old generated files.
[00:01:43] cd /wrkdirs/usr/ports/databases/cockroach/work/cockroach-v19.1.11/src/github.com/cockroachdb/cockroach/c-deps/jemalloc && autoconf
[00:01:43] mkdir -p bin
[00:01:43] go install -v ./pkg/cmd/prereqs
[00:01:43] touch bin/.submodules-initialized
[00:01:43] regenerating pkg/cli/zcgo_flags.go
[00:01:43] regenerating pkg/server/status/zcgo_flags.go
[00:01:43] regenerating pkg/storage/engine/zcgo_flags.go
[00:01:43] regenerating pkg/ccl/storageccl/engineccl/zcgo_flags.go
[00:01:43] regenerating pkg/cli/zcgo_flags_aarch64_portbld_freebsd13.0.go
[00:01:43] regenerating pkg/ccl/gssapiccl/zcgo_flags.go
[00:01:43] go tool compile: signal: illegal instruction (core dumped)
[00:01:43] gmake[1]: *** [Makefile:1553: bin/prereqs] Error 1


I've seen before that go compiled on rpi4+poudriere core dumps. But the go pkg downloaded from the pkg builders works fine.
I will investigate further when time permits and nobody beats me to it.
Regards,
Ronald.
Received on Tue Jun 22 2021 - 17:12:00 UTC

Original text of this message