many ports unbuildable without X11

From: Miroslav Lachman <000.fbsd_at_quip.cz>
Date: Sat, 17 Jul 2021 12:17:17 +0200
Hi,
as we are running FreeBSD on headless servers only we use Poudriere to 
build all packages without X11:

OPTIONS_UNSET= X11 GUI CUPS DOCS EXAMPLES NLS HAL

It works fine for years but few month ago I noticed problems when 
building math/pspp  PR 256146
Even if pspp has option UNSET+=GUI it still requires GTK and Cairo with 
X11 enabled. (error message: gtk3-3.24.27: Needs cairo with X11 support 
enabled), the same applies for libepoxy. It was not needed in the past 
years.
There were chain of problems where many other dependencies need to be 
rebuilt with X11 enabled.
When I updated ports tree to new quaterly yeasterday and run "poudriere 
bulk" it ends with another X11 related error because the chain of 
dependencies were changed. libGL was previously provided by mesa-libs 
but now libglvnd which must be built with X11 enabled too.

What changed so drastically that we cannot build packages without X11 
anymore?
Can this be fixed somehow?

Are there any official QA / exp run tests to build ports tree without X11?

Kind regards
Miroslav Lachman
Received on Sat Jul 17 2021 - 10:17:17 UTC

Original text of this message