Re: problem building gstreamer1

From: Chris <portmaster_at_bsdforge.com>
Date: Tue, 13 Jul 2021 10:56:48 -0700
On 2021-07-13 10:46, Kurt Jaeger wrote:
> Hi!
> 
>> 	For several weeks, attempts to build gstreamer1 have produced the
>> appended and a hung-but-killable process.
> 
> A test-build in poudriere was fine.
> 
>> 	This is way above my pay grade.
>> 	What have I screwed up?
> 
> Maybe it's the yacc/bison version you are using ?
> 
> There's a very simple message at the end:
> 
> ./grammar.y:799.1-12: warning: deprecated directive: %pure-parser
> use %define api.pure
> 
> Have you tried to patch grammar.y to change it accordingly ?
FWIW I just performed a build here with a ports tree pulled yesterday 
morning.
I logged the output, and I too get:

mv grammar.tab_tmp2.c grammar.tab.c
./grammar.y:799.1-12: warning: deprecated directive: ‘%pure-parser’, use 
‘%define api.pure’ [anual/html_node/Diagnostics.html#Wdeprecated]8;;\]
   799 | %pure-parser
       | ^~~~~~~~~~~~
       | %define api.pure
./grammar.y: warning: fix-its can be applied.  Rerun with option '--update'. 
[anual/html_node/Diagnostics.html#Wother]8;;\]
/usr/bin/flex --header-file=parse_lex.h -Ppriv_gst_parse_yy parse.l 
grammar.tab.h && \

(sorry for the ANSI)
So it appears that if the port needs a different parser/version, it should 
declare it. No?

HTH

--Chris

Received on Tue Jul 13 2021 - 17:56:48 UTC

Original text of this message