XFCE4 No Longer Displaying 3rd-Party Fonts.

From: Janky Jay, III <jankyj_at_unfs.us>
Date: Mon, 12 Jul 2021 14:49:06 UTC
Hi All,

    So, I'm unsure if this is where this should go, but it did happen
after a recent port (pkg) upgrade of a FreeBSD 13.0 desktop system that
I've been running. I'd moved from "quarterly" to "latest" and got the
updates and now my XFCE4 desktop doesn't display any of the fonts I was
previously using. I only have the three basic fonts options of "Dejavu",
"Luxi", and "Monospace."

    I did come across a post on the forums [1] that appears to be the
exact situation that I'm seeing. However, that topic was labeled as
"Solved" but I don't see any actual resolution to the problem. From the
sound of it, their Terminus font didn't work in XFCE4 nor in Fluxbox so
they used something else and it did work? If that's the case, I don't
really see that as a "fix."

    I've tried every suggestion in the forum post with the same results
that OP got (everything appears to there and picked up as expected,) yet
I'm still unable to use any of the fonts I've installed.

    Has anyone else come across this issue in any other WM/DE? Is there
something I've been completely missing, maybe? Any new ideas or
information on how I can get my fonts back would be greatly appreciated!


Janky Jay, III