Re: x11/nvidia-driver update to 470.63.01 seems to break GK106GLM [Quadro K2100M]

From: Kevin Bowling <kevin.bowling_at_kev009.com>
Date: Mon, 30 Aug 2021 09:32:18 -0700
On Sun, Aug 29, 2021 at 1:36 PM David Wolfskill <david_at_catwhisker.org> wrote:
>
> On Sun, Aug 29, 2021 at 01:32:19PM -0700, Kevin Bowling wrote:
> > See if it is reproducible with a 13 or main kernel, there is a locking change
> > which may interact differently on the different branches so that would
> > be a good thing to know.  This may need nvidia help since the error
> > seems to be deeper in the blob, they have a support forum where you
> > can link your report to start that.
>
> I had encountered (very!) similar results on
> head_at_main-n248984-08b9cc316a31 (from yesterday), so I believe it is thus
> reproducible.

Can you attempt to build run it with this in your make.conf:
WITH_DEBUG_PORTS=x11/nvidia-driver

Just as a sanity check please make sure you are building the port
against the exact kernel sources that will be booted with the above.

If there's a chance the shim code is involved we have a shot at doing
something or finding a better lead.  Otherwise your best bet is to
report it to nvidia support forum.  There is a report of a successful
outcome on a Kepler architecture card so it seems you are encountering
a more specific bug than HW generation and I'm not sure what to expect
yet.

https://forums.developer.nvidia.com/c/gpu-graphics/freebsd-solaris/147

> I'm AFK for the next ~1.5 hours...
>
> > ....
>
> Thanks!
>
> Peace,
> david
> --
> David H. Wolfskill                              david_at_catwhisker.org
> Life is not intended to be a zero-sum game.
>
> See https://www.catwhisker.org/~david/publickey.gpg for my public key.
Received on Mon Aug 30 2021 - 16:32:18 UTC

Original text of this message