Re: Port net-mgmt/telegraf does not build anymore since last version 1.19.3

From: Dr. Peter Voigt <pvoigt_at_uos.de>
Date: Thu, 26 Aug 2021 11:27:15 +0200
On Wed, 25 Aug 2021 17:42:13 +0200
"Dr. Peter Voigt" <pvoigt_at_uos.de> wrote:

Well, yesterday night I removed packages go and telegraf and removed
all corresponding files from /usr/ports/dist. Subsequently, both port
lang/go and net-mgmt/telegraf (1.19.3) could be built without any
issues.

My conclusion so far: Either upgrade of lang/go or of net-mgmt/telegraf
could not be performed cleanly for whatever reason.

Peter


> Version 1.19.2 net-mgmt/telegraf builds just fine on my system with
> FreeBSD 12.2-RELEASE-p10 (amd64).
> 
> But version 1.19.3 gives the following error:
> 
> ...
> 
> ===>>> Waiting on fetch & checksum for net-mgmt/telegraf <<<===
> # get
> https://proxy.golang.org/sigs.k8s.io/apiserver-network-proxy/konnectivity-client/_at_v/v0.0.14.zip
> # get
> https://proxy.golang.org/sigs.k8s.io/apiserver-network-proxy/konnectivity-client/_at_v/v0.0.14.zip:
> 200 OK (0.113s) # get
> https://proxy.golang.org/sigs.k8s.io/structured-merge-diff/v3/_at_v/v3.0.0.zip
> # get
> https://proxy.golang.org/sigs.k8s.io/structured-merge-diff/v3/_at_v/v3.0.0.zip:
> 200 OK (0.112s) # get
> https://proxy.golang.org/sigs.k8s.io/structured-merge-diff/v4/_at_v/v4.1.0.zip
> # get
> https://proxy.golang.org/sigs.k8s.io/structured-merge-diff/v4/_at_v/v4.1.0.zip:
> 200 OK (0.124s) # get
> https://proxy.golang.org/sigs.k8s.io/yaml/_at_v/v1.2.0.zip # get
> https://proxy.golang.org/sigs.k8s.io/yaml/_at_v/v1.2.0.zip: 200 OK
> (0.112s) # get
> https://proxy.golang.org/sourcegraph.com/sourcegraph/appdash/_at_v/v0.0.0-20190731080439-ebfcffb1b5c0.zip
> # get
> https://proxy.golang.org/sourcegraph.com/sourcegraph/appdash/_at_v/v0.0.0-20190731080439-ebfcffb1b5c0.zip:
> 200 OK (0.113s)
> 
> 
> ===>  License MIT accepted by the user
> ===>   telegraf-1.19.3 depends on file: /usr/local/sbin/pkg - found
> ===>   telegraf-1.19.3 depends on file: /usr/local/bin/go - found
> ===>   telegraf-1.19.3 depends on package: ca_root_nss>0 - found
> ===> Fetching all distfiles required by telegraf-1.19.3 for building
> ===> Fetching github.com/influxdata/telegraf dependencies
> ===>  Extracting for telegraf-1.19.3
> => SHA256 Checksum OK for
> go/net-mgmt_telegraf/telegraf-v1.19.3/v1.19.3.mod. => SHA256 Checksum
> OK for go/net-mgmt_telegraf/telegraf-v1.19.3/v1.19.3.zip. go: finding
> module for package github.com/Azure/go-amqp
> github.com/influxdata/telegraf/plugins/inputs/eventhub_consumer
> imports github.com/Azure/azure-event-hubs-go/v3 imports
> github.com/Azure/go-amqp: cannot find module providing package
> github.com/Azure/go-amqp: module lookup disabled by GOPROXY=off ***
> Error code 1
> 
> Stop.
> make: stopped in /usr/ports/net-mgmt/telegraf
> 
> ===>>> make build failed for net-mgmt/telegraf
> ===>>> Aborting update
> 
> ===>>> Update for net-mgmt/telegraf failed
> ===>>> Aborting update
> 
> 
> ===>>> You can restart from the point of failure with this command
> line: portmaster <flags> net-mgmt/telegraf 
> 
> This command has been saved to ~/portmasterfail.txt
> 
> The message suggests on issue with my GOPROXY settings. I have not
> changed any GO settings, e.g. I am using defaults only:
> 
> # env |grep -i proxy
> The above command yields no output.
> 
> # go env |grep -i proxy
> GONOPROXY=""
> GOPROXY="https://proxy.golang.org,direct"
> 
> I have contacted the port maintainer and he suggested to even remove
> the GO default setting. I tried:
> # go env -w GOPROXY=no
> according to https://golang.org/ref/mod#goproxy-protocol but the issue
> remains.
> 
> I appreciate any hints into the right direction.
> 
> Peter
> 
Received on Thu Aug 26 2021 - 09:27:15 UTC

Original text of this message