[Bug 269132] devel/rubygem-oj still no headers when building as non-root

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 24 Jan 2023 18:16:38 UTC

            Bug ID: 269132
           Summary: devel/rubygem-oj still no headers when building as
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: sunpoet@FreeBSD.org
          Reporter: marko.cupac@mimar.rs
          Assignee: sunpoet@FreeBSD.org
             Flags: maintainer-feedback?(sunpoet@FreeBSD.org)
 Attachment #239679 text/plain
         mime type:

Created attachment 239679
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=239679&action=edit


I have been instructed in #269020 to open a new ticket, so here it goes.

When building devel/rubygem-oj in poudriere as non-root, with the following set
in poudriere.conf:


...port gets successfully built, even though log shows header files are not
copied to approriate destination due to lack of permissions (see attached log).

This results in inability to build devel/rubygem-oj-introspect due to lack of
header files, and ultimately inability to build www/gitlab-ce, when building in
poudriere as non-root / nobody.

As no other port out of ~1300 I am currently building in poudriere has problem
with building as non-root, would it be possible to fix devel/rubygem-oj in a
way it can include header files when building as non-root, rather than asking
users of this port to start building ports as root?

Thank you in advance,

You are receiving this mail because:
You are the assignee for the bug.