[Bug 268652] Qt5: Some apps fails to start after upgrading to 5.15.8

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 21 Jan 2023 18:20:13 UTC

--- Comment #42 from Tomoaki AOKI <junchoon@dec.sakura.ne.jp> ---
(In reply to Tomoaki AOKI from comment #41)

I'm very confused but the problem disappeared by updating base
 from: commit 16dd69d46577bea5807d49340d894a68f8ea7d3a
 to  : commit c84ec3076e7de10d7475fd9694ad64603e264d88.
To confirm, several reboots and retry would be needed.

What cofuses me is that affected 3 apps worked fine on previous base before
updating ports (main)
 from: commit 885e50f344100a4ee6c5829ef87effef378d4f70
 to  : commit 2d00178fd4d952c698d3413800c3bd1b6cfc98a9
which is after commit 1fe9749d833c521b518e1190086ef02c7f3e31da.
In the meantime, updated Qt5 port installed was libreoffice (excluding what was
updated by commit 1fe9749d833c521b518e1190086ef02c7f3e31da itself).

What I did until previous post was as follows.
  1. Rebuilt again qt5-qmake.
  2. Rebuilt again qt5-gui.
  3. Rebuilt kf5-*
  4. Rebuilt again qt5-* except too heavy qt5-webkit.
  5. Rebuilt again *-qt5*.
  6. Rebuilt again vlc.
  7. Rebooted and tried vlc without luck.
  8. Updated base (weekly update).
     This includes 2 reboots before and after installworld.
  9. Tried vlc, which succeeded.
 10. Uninstalled gtk2-flavored audacious[-plugins]
 11. Reinstalled qt5-flavored audacious[-plugins]
 12. Tried audacious, whiche succeeded.

I'm now rebuilding editors/libreoffice, changing option from gtk3 to qt5.
Will report back when finished and tested.

You are receiving this mail because:
You are the assignee for the bug.