[Bug 266467] www/varnish7: Use upstream release archive and some improvements to Makefile
- Go to: [ bottom of page ] [ top of archives ] [ this month ]
Date: Sat, 17 Sep 2022 20:36:21 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=266467
Bug ID: 266467
Summary: www/varnish7: Use upstream release archive and some
improvements to Makefile
Product: Ports & Packages
Version: Latest
Hardware: Any
OS: Any
Status: New
Severity: Affects Only Me
Priority: ---
Component: Individual Port(s)
Assignee: dbaio@freebsd.org
Reporter: diizzy@FreeBSD.org
Flags: maintainer-feedback?(dbaio@freebsd.org)
Assignee: dbaio@freebsd.org
Created attachment 236645
--> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=236645&action=edit
Patch for varnish
- Use upstream release archive as recommended by USE_GITHUB section in Porters
Handbook
- Remove USES= compiler as there's no need to modify configure script (compile
tested with GCC 11)
- Remove unneeded gmake and readline dependency definition
- Use USES= localbase instead of CFLAGS variable
- Remove REINPLACE_CMD for gcc as it doesn't match anything
- Rearrange Makefile to follower Porters Handbook more closely and improve
readability
Compile and runtime tested on FreeBSD 13.1-STABLE #0
stable/13-n251817-0c4d13c521a (amd64) (make, make check-plist, make test)
Poudriere testport OK 12.3-RELEASE (amd64)
--
You are receiving this mail because:
You are the assignee for the bug.