[Bug 264070] deskutils/xpad: Systray icon no longer appears

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 18 May 2022 12:56:41 UTC

            Bug ID: 264070
           Summary: deskutils/xpad: Systray icon no longer appears
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: jgh@FreeBSD.org
          Reporter: junchoon@dec.sakura.ne.jp
             Flags: maintainer-feedback?(jgh@FreeBSD.org)
          Assignee: jgh@FreeBSD.org

After updating deskutils/xpad from 5.4.0_2 to 5.7.0, systray icon is no longer
appears and cannot open single, wanted note from right-click menu on systray
My desktop environment is x11/mate, with x11-wm/compiz.

Rebuilding all direct dependencies did not help.

5.4.0_2 worked just fine, except some Japanese titles are not shown properly on
right-click menu.

Looking into ChanegLog prompted on commit message, I suspect

 * Fix: Replace libappindicator with libayatana-appindicator, since
   libappindicator is not maintained. (#1964116)
 * Fix: App indicator (systray): make [Show All] / [Close All] menu
   items clickable

of Version 5.7 broke fallback mechanism from appindicator to systray.

libayatana-appindicator is not on ports collection, and 5.4.0_2 worked fine
without devel/libappindicator installed. (Even not depended upon.)

You are receiving this mail because:
You are the assignee for the bug.