[Bug 263778] Undefined Symbol Error - GL

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 05 May 2022 00:00:54 UTC

            Bug ID: 263778
           Summary: Undefined Symbol Error - GL
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Some People
          Priority: ---
         Component: Individual Port(s)
          Assignee: ports-bugs@FreeBSD.org
          Reporter: inbox@alleghenycomputer.com

First let me say thank you to all involved with getting the 6.0 version into
the ports tree!

I have it happily running on several newer workstations and laptops.

However, I did have an issue with two older laptops which use the
nvidia-driver-340 (latest version).  The prior version of xscreensaver worked
fine but version 6 does not.

The error I when launching from cmd line using any of the GL screensavers is:

ld-elf.xo.1:/usr/local/bin/xscreensaver-hacks/glslideshow: undefined symbol

The error on the desktop when trying to launch any GL screen saver is a black
screen with big red print  "glslideshow crashed with status 1"

I did some digging and see this is an issue with v6 and older video cards.

see:  https://bugs.gentoo.org/811885

From comment #1 of the above link, I did the following...

I edited the make file to include --with-glx \ in the CONFIGURE_ARGS section. 
I placed it right under --with-gl \ and then rebuilt xscreensaver.

It worked!  GL screensavers back in action under the legacy nvidia driver.

I am not saying it's the "proper" or "right" way to go about it, I'll let
other's figure that out.  I am just saying... it worked for me and hope this
helps other's who come across the same issue.

It might be nice to have an option to do something like this for those with
legacy hardware, etc.

You are receiving this mail because:
You are the assignee for the bug.