[Bug 262837] mail/postfix: exclusive lock on data_directory
- Go to: [ bottom of page ] [ top of archives ] [ this month ]
Date: Sat, 26 Mar 2022 16:52:08 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=262837
Bug ID: 262837
Summary: mail/postfix: exclusive lock on data_directory
Product: Ports & Packages
Version: Latest
Hardware: Any
OS: Any
Status: New
Severity: Affects Only Me
Priority: ---
Component: Individual Port(s)
Assignee: otis@FreeBSD.org
Reporter: peter.larsen@larsendata.dk
Assignee: otis@FreeBSD.org
Flags: maintainer-feedback?(otis@FreeBSD.org)
I have a setup where I have several postfix running with several configuration
directories, and predefined data directories.
It works fine In postfix 3.6.3,1 and previous versions
in the newly 3.7.x version in ports, I get this:
Mar 26 16:15:27 mail04 postfix/tlsmgr[12478]: fatal:
btree:/var/db/postfix/smtpd_tls_session_cache: unable to get exclusive lock:
Resource temporarily unavailable
Mar 26 16:15:28 mail04 postfix/master[12214]: warning: process
/usr/local/libexec/postfix/tlsmgr pid 12478 exit status 1
Mar 26 16:15:28 mail04 postfix/master[12214]: warning:
/usr/local/libexec/postfix/tlsmgr: bad command startup -- throttling
Mar 26 16:16:28 mail04 postfix/tlsmgr[12866]: fatal:
btree:/var/db/postfix/smtpd_tls_session_cache: unable to get exclusive lock:
Resource temporarily unavailable
Mar 26 16:16:29 mail04 postfix/master[12214]: warning: process
/usr/local/libexec/postfix/tlsmgr pid 12866 exit status 1
Mar 26 16:16:29 mail04 postfix/master[12214]: warning:
/usr/local/libexec/postfix/tlsmgr: bad command startup -- throttling
Mar 26 16:17:29 mail04 postfix/tlsmgr[14476]: fatal:
btree:/var/db/postfix/smtpd_tls_session_cache: unable to get exclusive lock:
Resource temporarily unavailable
my very blond guess would be, than even if I do set the data directory, it
somehow defaults to the standard directory, hence creating a lock issue
please advice
--
You are receiving this mail because:
You are the assignee for the bug.