[Bug 262216] devel/bazel 5.0.0 does not work after successful installation on freebsd 13.0

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 19 Mar 2022 15:52:07 UTC

--- Comment #18 from Ulas SAYGIN <ulassayginim@gmail.com> ---
(In reply to Klaus Aehlig from comment #16)
hi @Klaus Aehlig , thank you for your help.
it will be good to try it.
i understand that you dont need envoyproxy and you didnt use it.
in fact, i didnt use it before, all i want to try the port envoy but it turns
out finding bugs related to other things like bazel and openjdk.
now i know that our freebsd port tree successfully intall bazel but
it does not create openjdk tool chain for bazel and bazel community does not
support freebsd jdk tool chain. in this case, even for any java projects i cant
use bazel to compile it not only envoyproxy but also all projects which needs
jdk tool chain. i tried every possible action to make bazel work with local jdk
but no luck. lastly i tried compile bazel from source but i coulndt do it.
i created a bug report on their github issues and i also created freebsd bug
report about bazel port is not functioning well.
you may see it link below.
can i ask a favor, if you bazel works with java toolchain in your environment.
can you try to compile envoyproxy?

just you need to do this,and give feed about it?

thank you for you time and help and also thank you for patch , i will try.

git clone --single-branch --branch main https://github.com/envoyproxy/envoy.git

bazel build --announce_rc -c opt envoy


You are receiving this mail because:
You are the assignee for the bug.