[Bug 262338] www/gitlab-ce: start redis before gitlab-ce
- Go to: [ bottom of page ] [ top of archives ] [ this month ]
Date: Fri, 04 Mar 2022 11:57:09 UTC
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=262338
Bug ID: 262338
Summary: www/gitlab-ce: start redis before gitlab-ce
Product: Ports & Packages
Version: Latest
Hardware: Any
OS: Any
Status: New
Severity: Affects Only Me
Priority: ---
Component: Individual Port(s)
Assignee: mfechner@FreeBSD.org
Reporter: majo-bugs.freebsd.org@cerny.sk
Flags: maintainer-feedback?(mfechner@FreeBSD.org)
Assignee: mfechner@FreeBSD.org
After upgrading my system from FreeBSD 12.2 to 12.3 I noticed the following
error:
The GitLab Sidekiq job dispatcher is not running.
sidekiq.log: Error connecting to Redis on /var/run/redis/redis.sock
(Errno::ENOENT)
The error was caused by starting gitlab-ce before redis server. Probably the
rcorder has changed for my gitlab jail instance after upgrade to FreeBSD 12.3.
I have fixed the problem by adding `redis` to REQUIRE: in the rc.d startup
script:
# REQUIRE: LOGIN redis
Please consider adding `redis` to the REQUIRE: block in
/usr/local/etc/rc.d/gitlab for all users. Thanks.
--
You are receiving this mail because:
You are the assignee for the bug.