[Bug 265924] net-mgmt/netbox: FAILURE: DETAIL: PostgreSQL does not support leap seconds.

From: <bugzilla-noreply_at_freebsd.org>
Date: Thu, 18 Aug 2022 08:29:15 UTC

            Bug ID: 265924
           Summary: net-mgmt/netbox: FAILURE: DETAIL:  PostgreSQL does not
                    support leap seconds.
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Many People
          Priority: ---
         Component: Individual Port(s)
          Assignee: kai@FreeBSD.org
          Reporter: ohartmann@walstatt.org
             Flags: maintainer-feedback?(kai@FreeBSD.org)
          Assignee: kai@FreeBSD.org

Upgrading a 13.1-RELENG-p1 jail from python3.8 - > python3.9 as recommended in
UPDATING via pkg and updating net-mgmt/netbox from 3.1.11 to 3.2.8 (most recent
version as of today) in this vain results in a dysfunctional netbox
installation and in non-working migration procedure, as recommended at the end
of the install/upgrade process of net-mgmt/netbox. 

Issuing the first step:

python3.9 manage.py migrate

results in:

Traceback (most recent call last):
"/usr/local/lib/python3.9/site-packages/django/db/backends/base/base.py", line
244, in ensure_connection
  File "/usr/local/lib/python3.9/site-packages/django/utils/asyncio.py", line
26, in inner
    return func(*args, **kwargs)
"/usr/local/lib/python3.9/site-packages/django/db/backends/base/base.py", line
227, in connect
line 241, in init_connection_state
    timezone_changed = self.ensure_timezone()
line 234, in ensure_timezone
    cursor.execute(self.ops.set_time_zone_sql(), [timezone_name])
psycopg2.errors.InvalidParameterValue: time zone "UTC" appears to use leap
DETAIL:  PostgreSQL does not support leap seconds.


and more follow and it is always the same error report regarding PostgreSQL is
not supporting leap second (using databases/postgresql13-{server|client} as
from latest official repo).

I tried to search the net to figure out what is wrong here, I also can't find
ad hoc a solution/workaround.

You are receiving this mail because:
You are the assignee for the bug.