[Bug 258723] x11-wm/qtile black screen

From: <bugzilla-noreply_at_freebsd.org>
Date: Sat, 25 Sep 2021 18:36:20 UTC

            Bug ID: 258723
           Summary: x11-wm/qtile black screen
           Product: Ports & Packages
           Version: Latest
          Hardware: arm64
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: ericbsd@FreeBSD.org
          Reporter: b1ru@protonmail.com
             Flags: maintainer-feedback?(ericbsd@FreeBSD.org)
          Assignee: ericbsd@FreeBSD.org

I get a black screen when I try to use qtile.
No cursor and no default bindings working.

My .xinitrc is like this:

    exec qtile start

I also tried this, this did not work either:

    exec qtile 

The weird thing is when I tried this, it actually worked!

   qtile start&
   exec xterm

Of course, this isn't an ideal solution because If I close xterm, X closes too.

My FreeBSD version is:  13.0-RELEASE

No errors are generated in ~/.local/share/qtile/qtile.log when I try to start
qtile with "exec qtile start" in my .xinitrc.

I used the default make configuration of the port and its dependencies.

Any help appreciated :)

You are receiving this mail because:
You are the assignee for the bug.