[Bug 257398] emulators/wine-devel: Fail link if devel/libsysinfo installed: unix/virtual.o: in function `virtual_get_system_info': virtual.c:(.text+0x5bff): undefined reference to `sysinfo'

From: <bugzilla-noreply_at_freebsd.org>
Date: Sun, 05 Sep 2021 10:02:22 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=257398

Gerald Pfeifer <gerald_at_FreeBSD.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|In Progress                 |Closed
              Flags|merge-quarterly?            |merge-quarterly+
         Resolution|---                         |FIXED
            Summary|emulators/wine-proton: Fail |emulators/wine-devel: Fail
                   |link if devel/libsysinfo    |link if devel/libsysinfo
                   |installed: unix/virtual.o:  |installed: unix/virtual.o:
                   |in function                 |in function
                   |`virtual_get_system_info':  |`virtual_get_system_info':
                   |virtual.c:(.text+0x5bff):   |virtual.c:(.text+0x5bff):
                   |undefined reference to      |undefined reference to
                   |`sysinfo'                   |`sysinfo'

--- Comment #12 from Gerald Pfeifer <gerald_at_FreeBSD.org> ---
Yes, this makes sense to be pushed back to quarterly for wine-devel,
just I won't be able to do it myself (capacity-wise).

Based on iwtcex' response, no action for wine-proton, which should get
fixed with a future updates unless someone bothers to patch it locally.

wine-devel has been fixed (first locally, then upstream), so closing
this.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Sun Sep 05 2021 - 10:02:22 UTC

Original text of this message