[Bug 259279] sysutils/py-salt 3004 requires pyzmq<22.0.0,>=17.0.0 in 2021Q4

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 19 Oct 2021 17:15:12 UTC

            Bug ID: 259279
           Summary: sysutils/py-salt 3004 requires pyzmq<22.0.0,>=17.0.0
                    in 2021Q4
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Many People
          Priority: ---
         Component: Individual Port(s)
          Assignee: ports-bugs@FreeBSD.org
          Reporter: danmcgrath.ca@gmail.com
                CC: christer.edwards@gmail.com
                CC: christer.edwards@gmail.com
             Flags: maintainer-feedback?(christer.edwards@gmail.com)


I was noticing that after an upgrade from 3003.3_1 to 3004 that running high
states shows some warnings about the version of pyzmq installed:


Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line
568, in _build_master
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line
886, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line
777, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (pyzmq 22.3.0
Requirement.parse('pyzmq<22.0.0,>=17.0.0'), {'salt'})


 #> pkg info | grep pyz
py38-pyzmq-22.3.0              Python bindings for ZeroMQ


The states seem to run fine, so I am not sure if this is just a neglected
requirements that was missed, or if there are actual problems with 22.3.0 that
is used in 2021Q4.

Anyway, thanks in advance! o/

You are receiving this mail because:
You are the assignee for the bug.