[Bug 256293] editors/lazarus-qt5 - Not working with Wayland (sway)

From: <bugzilla-noreply_at_freebsd.org>
Date: Mon, 31 May 2021 13:41:11 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256293

            Bug ID: 256293
           Summary: editors/lazarus-qt5 - Not working with Wayland (sway)
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: acm_at_FreeBSD.org
          Reporter: stephan_at_lichtenauer.co.za
          Assignee: acm_at_FreeBSD.org
             Flags: maintainer-feedback?(acm_at_FreeBSD.org)

If I start lazarus-qt5-2.0.10_1 (installed from packages) under sway (Wayland)
and FreeBSD 13 with i915 KMS drivers, lazarus fails to start with an exception
(before any window appears):

$ lazarus
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $000000000044F43C
  $00007FFFFFFFF003
  $0000000000572469
  $00000000006FCAC8
  $00000000006FC45A
  $00000000006F807C
  $0000000000600B99
  $0000000000600A9F
  $000000000048D83A
[FORMS.PP] ExceptionOccurred


If I force Lazarus to use the X11 backend with the following command, Lazarus
works fine, so the error is very likely related to the Wayland backend:

$ QT_QPA_PLATFORM=xcb lazarus

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Mon May 31 2021 - 13:41:11 UTC

Original text of this message