[Bug 256793] x11-wm/sway: WLR_RENDERER=vulkan is broken

From: <bugzilla-noreply_at_freebsd.org>
Date: Wed, 23 Jun 2021 19:12:53 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256793

            Bug ID: 256793
           Summary: x11-wm/sway: WLR_RENDERER=vulkan is broken
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: jbeich_at_FreeBSD.org
          Reporter: evgeniy_at_khramtsov.org
          Assignee: jbeich_at_FreeBSD.org
             Flags: maintainer-feedback?(jbeich_at_FreeBSD.org)

$ WLR_RENDERER=vulkan
[wlr] [render/vulkan/vulkan.c:206] Could not create instance:
ERROR_LAYER_NOT_PRESENT (-6)
[wlr] [render/vulkan/renderer.c:15251] creating vulkan instance for renderer
failed
[wlr] [backend/drm/renderer.c:351] Failed to create renderer
[wlr] [backend/backend.c:2301] Failed to create DRM backend

ports tree: https://codeberg.org/ei/ports/commits/branch/ei

QTJ2 UHD 630 PCI ID 0x3E9B
drm-current-kmod
gl=libglvnd,mesa-devel

graphics/mesa-devel $ make -V SELECTED_OPTIONS
LIBUNWIND LTO VKLAYERS WAYLAND ZSTD anv iris

x11-toolkits/wlroots $ make -V SELECTED_OPTIONS
OPENGL VULKAN

x11-wm/sway $ make -V SELECTED_OPTIONS
BASU PIXBUF

sway started via DRM backend and seatd.

benchmarks/vkmark runs fine, I don't know anything about Vulkan and/or what
uses VK layers, also I don't play any games.

If you have any idea how to help to debug this, let me know.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Wed Jun 23 2021 - 19:12:53 UTC

Original text of this message