[Bug 256620] x11/nvidia-driver whines NVRM: Xid (...): 69, pid=..., Class Error: ChId 0009

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 15 Jun 2021 16:08:32 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256620

            Bug ID: 256620
           Summary: x11/nvidia-driver whines NVRM: Xid (...): 69, pid=...,
                    Class Error: ChId 0009
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: danfe_at_FreeBSD.org
          Reporter: david_at_catwhisker.org
             Flags: maintainer-feedback?(danfe_at_FreeBSD.org)
          Assignee: danfe_at_FreeBSD.org

During the last few days, I noted that on rebooting my laptop, I see NVRM
messages on the console; after reviewing
https://docs.nvidia.com/deploy/xid-errors/, I checked /var/log/messages, and
see them there, as well (which makes them a little easier to copy/paste).

The system is running:
FreeBSD localhost 12.2-STABLE FreeBSD 12.2-STABLE #1065
stable/12-n233296-71efecb7eb1: Tue Jun 15 03:32:32 PDT 2021    
root_at_localhost:/common/S1/obj/usr/src/amd64.amd64/sys/CANARY  amd64 1202507
1202507

today.  (I update base FreeBSD & installed ports daily; the Nvidia kernel
modules are rebuilt every time the kernel is rebuilt.)

The x11/nvidia-driver is:
localhost(12.2-S)[4] pkg info -o nvidia\*
nvidia-driver-460.80           x11/nvidia-driver
nvidia-settings-460.73.01      x11/nvidia-settings
nvidia-xconfig-460.73.01       x11/nvidia-xconfig

The messages start with the first shown, then some number of the second:
<2>1 2021-06-15T13:55:52.579431+00:00 localhost kernel - - - NVRM: GPU at
PCI:0000:01:00: GPU-4646efb0-6baa-1b48-6437-fd72a741be20
<2>1 2021-06-15T13:55:52.579453+00:00 localhost kernel - - - NVRM: Xid
(PCI:0000:01:00): 69, pid=1124, Class Error: ChId 0009, Class 0000902d, Offset
000008b0, Data ffffffff, ErrorCode 00000004
<2>1 2021-06-15T13:57:51.370359+00:00 localhost kernel - - - NVRM: Xid
(PCI:0000:01:00): 69, pid=1124, Class Error: ChId 0009, Class 0000902d, Offset
000008b0, Data fffff103, ErrorCode 00000004
<2>1 2021-06-15T14:04:22.315412+00:00 localhost kernel - - - NVRM: Xid
(PCI:0000:01:00): 69, pid=1124, Class Error: ChId 0009, Class 0000902d, Offset
000008b0, Data fffff883, ErrorCode 00000004
...
<2>1 2021-06-15T15:21:09.300094+00:00 localhost kernel - - - NVRM: Xid
(PCI:0000:01:00): 69, pid=1124, Class Error: ChId 0009, Class 0000902d, Offset
000008b0, Data fffff103, ErrorCode 00000004

The Nvidia Web page (cited above) seems to indicate that Xid 69 is "Graphics
Engine class error," and is an error in the HW, the driver, or both.

Other than a visual "glitch" that might correspond with issuing one of the
above "whines," I am not seeing overly disruptive symptoms.  (So: no kernel
panics; no Xorg crashing.  I don't try to play real-time role-playing games.)

So I'm documenting this in case it might help shed some light on more
disruptive issues that are being reported.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Tue Jun 15 2021 - 16:08:32 UTC

Original text of this message