[Bug 256491] devel/openocd: Update to 0.11.0, enable USB support for J-Link

From: <bugzilla-noreply_at_freebsd.org>
Date: Tue, 08 Jun 2021 23:24:01 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256491

            Bug ID: 256491
           Summary: devel/openocd: Update to 0.11.0, enable USB support
                    for J-Link
           Product: Ports & Packages
           Version: Latest
          Hardware: Any
                OS: Any
            Status: New
          Severity: Affects Only Me
          Priority: ---
         Component: Individual Port(s)
          Assignee: skreuzer_at_FreeBSD.org
          Reporter: saper_at_saper.info
          Assignee: skreuzer_at_FreeBSD.org
             Flags: maintainer-feedback?(skreuzer_at_FreeBSD.org)

Created attachment 225652
  --> https://bugs.freebsd.org/bugzilla/attachment.cgi?id=225652&action=edit
update port to 0.11.0

This is an update of openocd package to 0.11.0

I have also added CONFIGURE_ENV to make libjaylink accept our libusb (otherwise
it uses pkg-config and says our libusb is too old).

I think there should be an UPDATING entry added for this one, since some
configuration may not work as it were in 0.10.0.

Nice explanation how to fix the configuration if needed:

https://visualgdb.com/support/chainposition/

(I am pretty new to this software but now it manages to detect my J-Link
equipped board).

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Tue Jun 08 2021 - 23:24:01 UTC

Original text of this message