[Bug 256427] [NEW PORT] finance/py-chiapos: Chia proof of space plotting, proving, and verifying (wraps C++)

From: <bugzilla-noreply_at_freebsd.org>
Date: Sun, 06 Jun 2021 00:14:43 +0000
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256427

Kubilay Kocak <koobs_at_FreeBSD.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Keywords|                            |needs-patch
                 CC|                            |risner_at_stdio.com
              Flags|                            |maintainer-feedback?(risner
                   |                            |_at_stdio.com)

--- Comment #1 from Kubilay Kocak <koobs_at_FreeBSD.org> ---
Review items:

 - Upstream says this uses/needs cmake, but the port uses USES=cmake. Is it
required?
 - setup.py has special env vars that modify the build, are any of these
wanted, needed, useful as OPTIONs?
 - USE_CXXSTD *may* be useful here if you need to use USES=compiler:<value> [2]
 - setup.py says 3.7+, port says 3.6+. Intentional? [3]
 - For python dependencies, use package name declarations, rather than file/dir
dependency declarations, as the latter does'nt support <version-specs>, which
python packages need, and policy requires matching on. [4]
 - WWW: url should match setup.py=url in almost all cases (its canonical) [5]
 - When running commands, 

[1] setup.py BUILD_VDF_CLIENT BUILD_VDF_BENCH 
[2] setup.py: "at least C++11 support " "is needed!"
[3] setup.py: python_requires=">=3.7"
[4] BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pybind11>=2.5.0 ... (per setup.py
setup_requires version-spec). See Also PythonPolicy#Dependencie
[5] setup.py: url="https://github.com/Chia-Network/chiavdf",

-- 
You are receiving this mail because:
You are the assignee for the bug.
Received on Sun Jun 06 2021 - 00:14:43 UTC

Original text of this message